Jump to content
Sign in to follow this  
rjunior

ControlSend e/ou Send trocando caracteres ao enviar

Recommended Posts

Bom dia!

 

Gostaria de ajuda com o seguinte problema: quando enviou o caminho/nome_arquivo para um campo de um determinado programa, esporadicamente o mesmo troca alguns caracteres, ou seja, não é sempre que ocorre.

 

Ex: C:\Nome_Arquivo.XLSX para C;\Nome_Arquivo.XLSX ou C:|Nome_Arquivo.XLSX ou C:\NLme_Arquivo.XLSX, etc.

 

 

Exemplo no código:

 

ControlSend("Relatório de acompanhamento", "", "[CLASS:ThunderRT6TextBox; INSTANCE:1]", “C:\Nome_Arquivo.XLSX")

ou

ControlClick Relatório de acompanhamento ", "", "[CLASS:ThunderRT6TextBox; INSTANCE:1]")

Send(“C:\Nome_Arquivo.XLSX")

 

Desde já agradeço se alguém puder me ajudar.

Edited by rjunior

Share this post


Link to post
Share on other sites

Boa tarde,

Tenta usar assim:
Send(“C:\Nome_Arquivo.XLSX", 1)
ControlSend("Relatório de acompanhamento", "", "[CLASS:ThunderRT6TextBox; INSTANCE:1]", “C:\Nome_Arquivo.XLSX", 1)

 

aguardo resultado.

Share this post


Link to post
Share on other sites

Boa tarde,

 

Tenta usar assim:

Send(“C:\Nome_Arquivo.XLSX", 1)

ControlSend("Relatório de acompanhamento", "", "[CLASS:ThunderRT6TextBox; INSTANCE:1]", “C:\Nome_Arquivo.XLSX", 1)

 

aguardo resultado.

Obrigado! Alterei meu código. Vou aguardar para ver se não ocorre novamente.

Edited by rjunior

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×